FlowVella is NOT affected by Heartbleed

April 11, 2014

Flowboard is not affected by the heartbleed bug

Quick update: There has been a lot of talk about the Heartbleed Bug and we want to let you know that FlowVella is NOT affected. We have been running a version of SSL that has NOT been compromised. You do NOT need to change your password, but if you’d like to, you can do so here.  At FlowVella, we care about security and privacy and we want you to know that your passwords are safe with us.